Metamask Wallet Issue

Incident Report for Flow

Resolved

This incident has now been resolved, and Metamask transactions on Flow EVM are now working normally.
Posted May 01, 2025 - 01:05 UTC

Investigating

Metamask is currently experiencing issues on Flow EVM, causing their wallet transactions to fail. The Flow team is actively working to resolve the issue.

In the meantime, the Flow EVM network and all other wallets, such as Flow Wallet, continue to operate normally.
Posted Apr 30, 2025 - 23:11 UTC