Flow Mainnet Experiencing Degraded Performance

Incident Report for Flow

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 05:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2025 - 17:40 UTC

Investigating

We are currently observing a lower-than-usual block finalization rate (blocks/second) on Flow mainnet. As a result, users may experience increased time to finalization and time to seal for their transactions.

We are investigating the issue, and we will provide updates as we gather more information.
Posted Mar 13, 2025 - 04:55 UTC
This incident affected: Flow mainnet core components (Block Finalization).