Flow Mainnet Network Issue

Incident Report for Flow

Resolved

The incident has been resolved and the network has resumed.
Posted Feb 24, 2026 - 05:13 UTC

Monitoring

The root cause of the issue has been resolved, and block production has resumed, though it is currently progressing slowly. Consensus node operators are actively upgrading their nodes, and once a majority of the consensus nodes in the network have completed the update, block sealing is expected to return to normal performance.
Posted Feb 24, 2026 - 04:59 UTC

Identified

Flow is still in maintenance as the team works to restore full operations. The issue was caused by an incomplete node update in preparation for tomorrow’s height coordinated upgrade, which triggered a consensus safety mechanism that halted block sealing. Flow engineers are actively working on a fix, and the next update will be shared at 10 PM PT.
Posted Feb 24, 2026 - 04:07 UTC

Investigating

Block sealing on Flow mainnet has stopped. We are investigating the issue.
Posted Feb 24, 2026 - 01:15 UTC
This incident affected: Flow mainnet core components (Block Sealing).