We have successfully completed testing of dynamic transaction fees on Testnet. During the test, the surge factor was adjusted sequentially to 1.1, 2, 4, 10, 100, 0.9, and back to 1.
Cadence 1. Transaction fees updated correctly according to each surge factor. 2. Flow Wallet successfully submitted transactions with the updated fees.
EVM 1. Transaction fee estimates were reported accurately: Forge (used for a contract upgrade transaction) Metamask (used for a token transfer) 2. Transactions were charged correctly in both cases, reflecting the surge factor adjustments.
Additional Validation Flowscan also reported the surge factor correctly throughout the test.
Posted Aug 29, 2025 - 17:52 UTC
Verifying
The surge factor is back to 1.0. Transactions should now cost the same as they did before the test.
Posted Aug 29, 2025 - 17:32 UTC
Update
The surge factor on testnet is now set to 0.9. Transactions fees are now lesser by 10% on testnet.
Posted Aug 29, 2025 - 17:27 UTC
Update
The surge factor on testnet is now set to 100. Transactions fees are now 10x on testnet.
Posted Aug 29, 2025 - 17:10 UTC
Update
The surge factor on testnet is now set to 10. Transactions fees are now 10x on testnet.
Posted Aug 29, 2025 - 16:23 UTC
Update
The surge factor on testnet is now set to 4. Transactions fees are now 4x on testnet.
Posted Aug 29, 2025 - 16:18 UTC
Update
The surge factor on testnet is now set to 2. Transactions fees are now 2x on testnet.
Posted Aug 29, 2025 - 16:05 UTC
Update
The surge price on testnet is now 1.1. Transactions fees will cost 10% more.
Posted Aug 29, 2025 - 15:37 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 29, 2025 - 15:00 UTC
Scheduled
We will be conducting a dynamic transaction fee test on Flow Testnet to validate that transaction fees adjust as expected during periods of simulated network overload.
What to Expect
- Transaction fees will progressively increase by changing the surge factor by factors of 1.1×, 2×, 4×, 10×, and 100×. - dApps and wallets are expected to automatically adjust by paying the correct transaction fees. - We will be monitoring transaction error rates and system behavior throughout the test. - This test will be conducted on testnet and will have no impact on mainnet
> If you notice your dApps or wallets being depleted faster during the test, please fund them with additional FLOW. You can use the testnet faucet (https://faucet.flow.com/fund-account) to top up the payer account.