Flow Testnet Network Issue

Incident Report for Flow

Resolved

The incident has been resolved and normal operation on testnet has resumed.
Posted Sep 23, 2025 - 19:27 UTC

Identified

Collection nodes have run into an issue on testnet due to which block production has been impacted.
We are fixing the issue right now.
No impact on Flow mainnet.
Posted Sep 23, 2025 - 19:17 UTC
This incident affected: Flow Testnet.