Sealing & Finalization halted on Testnet

Incident Report for Flow

Postmortem

Postmortem: Testnet Sealing and Finalization Interruption – July 10, 2025

Summary

On July 10, 2025, from 11:02 AM to 11:22 AM PST, Testnet experienced a temporary halt in block sealing and finalization. The issue was identified and resolved within 20 minutes. Mainnet remained fully operational and was not affected at any point.

Root Cause

An internal testing framework inadvertently interfered with Testnet node communications, resulting in a disruption to the consensus process. This occurred due to overlapping configurations between the testing environment and Testnet.

Resolution and Preventative Measures

To ensure this does not happen again:

  • Firewall rules have been updated to sandbox the internal testing framework, fully isolating it from Testnet environments.
  • The testing framework has also been modified to avoid any attempts to connect to or interact with the Testnet network.

Thank you,
Flow Team

Posted Jul 11, 2025 - 23:24 UTC

Resolved

The issue has been resolved and the network has fully recovered.
Please note that this incident impacted Testnet only — Mainnet remained unaffected and continues to operate normally.
Posted Jul 10, 2025 - 19:10 UTC
This incident affected: Flow Testnet.