Flow Testnet Network Issue

Incident Report for Flow

Postmortem

Yesterday 2/11, Flow Testnet experienced an outage during routine maintenance.

What Happened

The Flow team was performing maintenance to ensure testnet consensus nodes had enough disk space. During this work, a disk space reclamation process was run.

There was a flaw in this process when applied to consensus nodes that caused the DKG file to be deleted. Once a majority of the nodes were updated, they were no longer able to finalize blocks. As a result, finalization halted and the network stopped progressing.

Please note: Mainnet was not impacted.

Recovery

Possible recovery paths were evaluated. The safest and least disruptive way to restore the network was to perform a full network upgrade on testnet.

The upgrade restored consensus and returned the network to a healthy state.

EVM Follow Up

After the upgrade, EVM nodes encountered a separate issue and were not able to smoothly transition to the new network state. Additional remediation was required to bring EVM services back into sync.

Next Steps

  • Updating and testing the disk space reclamation process, adding more safety checks to ensure critical consensus state is preserved, along with clearer documentation.
  • Improving the EVM gateway to make it more robust during network upgrades and transitions.
  • Reviewing alerting and operational safeguards to surface issues more quickly.
Posted Feb 12, 2026 - 21:30 UTC

Resolved

The issue has been resolved with a full network upgrade (spork) on testnet
Posted Feb 12, 2026 - 05:33 UTC

Update

Flow Testnet will be undergoing a network upgrade (spork) to recover from the current issue.
Posted Feb 12, 2026 - 04:17 UTC

Investigating

Block production on testnet has halted.
We are currently investigating the issue.

No impact on mainnet.
Posted Feb 12, 2026 - 03:21 UTC
This incident affected: Flow Testnet.