The network upgrade is underway. State extraction is currently in process and should be done in ~1 hour. After state extraction, the next step is verification of the migrated state that will take ~40 mins.
Posted Oct 22, 2025 - 14:18 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 22, 2025 - 13:00 UTC
Update
Reminder: Flow mainnet network upgrade tomorrow.
Posted Oct 21, 2025 - 22:34 UTC
Update
Forte, the biggest upgrade to Flow since Crescendo (https://flow.com/upgrade/crescendo), is coming to mainnet in 7 days. Forte introduces a new era of onchain automation and composability on Flow, empowering developers and AI agents building on Flow.
Reminder - Flow mainnet will be unavailable during the maintenance window. During the maintenance, any updates will be shared on the Flow Status page.
Reminder - Flow mainnet network upgrade on Wednesday, 22 October 2025. Please note: the upgrade will start at 1:00 pm UTC on that date.
Posted Sep 23, 2025 - 19:58 UTC
Scheduled
Forte upgrades Flow with the tools and performance to make Flow the best-in-class option for developers looking to build on and with AI. By tapping into the developer friendliness of Cadence, launching new features, creating a library of components for developers to build from, upgrading the protocol and refining Flow tokenomics, Forte makes the dream of building consumer-ready onchain applications with AI a reality.
Flow Mainnet Maintenance Flow Mainnet will be upgrading on Wednesday, 22 October 2025, 1pm UTC (6am PT).