Flow Mainnet and Testnet Operational

Incident Report for Flow

Resolved

The Google Cloud outage has now been resolved.

We can confirm that there was no impact on Flow mainnet or testnet during this period. All systems remain fully operational.

Thank you for your understanding.
Posted Jun 12, 2025 - 23:31 UTC

Monitoring

The Flow mainnet and testnet are functioning normally.

However, we are currently monitoring a Google Cloud outage that may impact some API endpoints and third-party integrations. While core network operations are unaffected, services relying on Google-hosted components may experience intermittent issues or degraded performance.

We will continue to monitor the situation closely and provide updates as more information becomes available.

Thank you for your patience.
Posted Jun 12, 2025 - 19:36 UTC
This incident affected: Flow Testnet, Flow mainnet core components (Collection Finalization, Block Finalization, Transaction Execution, Block Sealing), and Flow mainnet Access APIs (GRPC API, GRPC Web API, REST API, EVM Gateway).